Outage
Incident Report for SchedulePro
Postmortem

Starting at approximately 1:59am PDT on 19 Apr 2021, an internal SchedulePro service account had a credential certificate revoked without prior warning. Our monitoring system started to issue alerts but we believe the service was still generally healthy at that time. At approximately 4:00am PDT, the SchedulePro system started to scale up to manage increases in user load and these new instances had issues coming online due to the certificate issue. The overall service was degraded at this point in time: blocking access to all users. Initial attempts to solve the problem with a service restart failed and further troubleshooting was then undertaken. The root cause was identified at approximately 7:47am PDT and rollout of the fix was completed at approximately 8:55am PDT.

Posted May 12, 2021 - 15:18 PDT

Resolved
Server outage affecting all production environments. Ongoing investigation. We will update when we have more information.
Posted Apr 19, 2021 - 02:30 PDT