SchedulePro Outage

Incident Report for SchedulePro

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 12:00 PDT

Monitoring

The API certificate has been updated to resolve this issue. We are continuing to monitor for any further issues at this time until we know it has been fully resolved.
Posted Sep 14, 2025 - 11:36 PDT

Identified

The team has uncovered a bad certificate with our API, which is impacting user logins and access to our mobile applications at this time. We are working as quickly as we can to get this resolved and will provide another update once we know it has been resolved.
Posted Sep 14, 2025 - 11:04 PDT

Investigating

We are currently investigating an outage on SchedulePro preventing users from logging in. We will provide an update once we have one, and apologize for the inconvenience.
Posted Sep 14, 2025 - 10:53 PDT
This incident affected: Time & Attendance, API, System Access, User Communication, and Scheduling.