SchedulePro Currently Down
Incident Report for SchedulePro
Resolved
The team monitored the site and the issue is now resolved.
Posted Feb 05, 2024 - 07:20 PST
Monitoring
Our team was able to resolve the issues impacting access to SchedulePro. We will continue monitoring the site.
Posted Feb 05, 2024 - 01:34 PST
Investigating
Currently users are unable to access SchedulePro through the website or the mobile app. Our team is investigating the cause.
Posted Feb 05, 2024 - 00:47 PST
This incident affected: Time & Attendance, API, System Access, User Communication, and Scheduling.