Timesheets not operational
Incident Report for SchedulePro
Resolved
This incident has been resolved, Timesheets feature is operating normally
Posted Oct 12, 2021 - 18:55 PDT
Identified
We have determined an issue exists with accepting Timesheets following a recent deployment. Our Engineering team is actively addressing the issue. Projected time to resolve is by 7pm PT. We will post updates as more information is available.
Posted Oct 12, 2021 - 18:37 PDT
This incident affected: Time & Attendance.