Manage Leave Request page not operational
Incident Report for SchedulePro
Resolved
This incident has been resolved.
Posted Oct 08, 2021 - 18:32 PDT
Investigating
There is a known issue with the Manage Leave Request page. A 404 error page appears when trying to access it. Our Engineers are actively troubleshooting, and we will provide updates as they come available.
Posted Oct 08, 2021 - 18:06 PDT
This incident affected: Time & Attendance.