Login Issues
Incident Report for SchedulePro
Resolved
The login issues have been resolved by the provider.
Posted Jul 12, 2021 - 14:40 PDT
Investigating
Some users are having issues connecting to SchedulePro. Our provider is performing ongoing investigation for the connectivity issues. In some cases, retrying login attempts will allow access to the system.
Posted Jul 12, 2021 - 12:05 PDT
This incident affected: System Access.