SchedulePro Currently Down
Incident Report for SchedulePro
Postmortem

The SchedulePro platform was down from 4:02 to 5:53 AM Pacific Time. There was an expiration of internal credentials that control communication permissions between our systems. We have renewed the credentials and updated our processes surrounding future updates to ensure that expirations are not encountered.

Posted Apr 19, 2023 - 10:49 PDT

Resolved
The SchedulePro platform was down from 4:02 to 5:53 AM Pacific Time. There was an expiration of internal credentials that control communication permissions between our systems. We have renewed the credentials and updated our processes surrounding future updates to ensure that expirations are not encountered.
Posted Apr 19, 2023 - 10:45 PDT
Monitoring
Our team identified and corrected the issues impacting SchedulePro. As of 5:53am Pacific Time, all systems have been restored. We will continue to monitor our servers.
Posted Apr 19, 2023 - 06:17 PDT
Identified
Our team has identified the problem and we hope to have services back within the next 30 minutes. We will provide an update when services are fully restored.
Posted Apr 19, 2023 - 05:34 PDT
Investigating
Our team is actively investigating why the SchedulePro system is down. We are working to resolve this and will provide an update as soon as possible.
Posted Apr 19, 2023 - 05:14 PDT
This incident affected: Time & Attendance, API, System Access, User Communication, and Scheduling.